Tu servidor está ejecutando la versión 5.2.3 de PHP, pero WordPess 3.5.1 necesita, al menos, la versión 5.2.4.